Issue while adding Picture Viewer Sample web part

Aug 19, 2008 at 1:26 PM
Edited Aug 19, 2008 at 1:27 PM

Hi,


I downloaded Picture Viewer Sample web part from http://www.ssblueprints.net/sharepoint/  and try to deploy it.


I run the setup file and it got installed successfully, after that i activated it in Site Collection Features.


But when i try to add Picture Viewer web part to the page, I got an error message saying that

 

Unable to add selected web part(s).

Silver light Blueprint for SharePoint: The Media Viewer Web Part: Cannot import SL.Sharepoint.MediaViewer Web Part.


Your assistance is appreciated.

 

Pavan Raj | Software Engineer

 

 

 

 

 

 

Coordinator
Aug 19, 2008 at 2:14 PM

Have you edited the web.config file in the root directory of your SharePoint folder?

This sounds like you may have not added the web part as a safe control in the web.config file--see below for example safe control entries.
 
Steve

------------------------------

    <SafeControls>

                   ...

      <SafeControl Assembly="SL.SharePoint.HelloSilverlight2, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bb99f30c0098259c" Namespace="SL.SharePoint.WebParts" TypeName="*" Safe="True" />

      <SafeControl Assembly="HelloWorldSLB2, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9f4da00116c38ec5" Namespace="HelloWorldSLB2" TypeName="HelloWorldSLB2" Safe="True" />

      <SafeControl Assembly="SL.SharePoint.SliderControl, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9f4da00116c38ec5" Namespace="SL.SharePoint.SliderControl" TypeName="SliderControlField" Safe="True" />

      <SafeControl Assembly="MediaPlayer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=9f4da00116c38ec5" Namespace="MediaPlayer" TypeName="MediaPlayer" Safe="True" />

           <SafeControl Assembly="Microsoft.Office.Workflow.Feature, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Workflow.Feature" TypeName="ProcessAllTasksButton" Safe="True" />

      <SafeControl Assembly="Microsoft.Office.Excel.WebUI, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" Namespace="Microsoft.Office.Excel.WebUI" TypeName="*" />

            ...
      
    </SafeControls>

Aug 21, 2008 at 7:16 AM

Hi,

 

After running the setup file I see <SafeControl Assembly="SL.SharePoint.MediaViewer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bb99f30c0098259c" Namespace="SL.SharePoint.WebParts" TypeName="*" Safe="True" /> this safe tag, which is been added to web.config file. But still I face same error message saying that 
  

Unable to add selected web part(s).

Silver light Blueprint for SharePoint: The Media Viewer Web Part: Cannot import SL.Sharepoint.MediaViewer Web Part.


Your assistance is appreciated.

 Pavan Raj | Software Engineer

May 12, 2009 at 6:57 PM

I am experiencing the same behaviour – I am unable to import this web part.

 

The installation procedure successfully edited the required web.config file on the host server and set the <safecontrol> flag. Are ALL of the webparts required in order to use them successfully?

 

Jun 5, 2009 at 2:59 PM

Same thing here. Even with the Hello World. Man, if we can't get Hello World working, that isn't a lot.