Problem porting to another server

Oct 10, 2008 at 5:29 PM
I have the blueprints workinig on my development machine (a W2k3 server with VS2008), but have not been able to migrate to another server.   Followed the FAQ and installed SP1, NET3.5, Silverlight plug-in and SDK.  Copied system.web.silverlight into GAC and updated web.config of target website.  Also created XAPS document library in target website, and added xap files.  After copying the solution created by VS2008 (in bin/debug directory) and modifying the url, I can run the setup script to add solution and deploy, but activate fails. 

Error for HelloWorld is "Failed to instantiate file "SL.XAML.HelloWorld.xap" from module "<null>":  The specified list does not exist. 

Error for MediaViewer is "Failed to instantiate file "SL.XAML.MediaViewer.xap" from module "XAP": The specified list does not exist.

Any ideas?

Thanks.
Nov 6, 2008 at 8:11 PM
I am also stuck up at the same point by getting similar error "Failed to instantiate file "SL.XAML.HelloWorld.xap" from module "<null>":  The specified list does not exist."

I am running Window 2008 server with .NET 3.5 SP1, SL 2 SDK installed in my box. Appreciate any help on this.

Thanks in advance.
Nov 7, 2008 at 1:34 AM
Edited Nov 7, 2008 at 1:51 AM

We had the same error.  In our case it was due to the name of the document library that we placed the xap files in.  The URL to our library called XAPS is actually XAPS1 i.e. /XAPS1/Forms/AllItems.aspx.  Not sure why this happens.. So to fix this we edited the module section of the SLHelloWorld.xml file :-

<Module Url="XAPS1" RootWebOnly="TRUE">
<File Path="SL.XAML.HelloWorld.xap" Url="SL.XAML.HelloWorld.xap" Type="GhostableInLibrary"></File>
</Module>

and in the SLHelloWorld.cs file ctl.Source :- 

ctrl.Source = SPContext.Current.Site.Url + "/XAPS1/SL.XAML.HelloWorld.xap";


Deploy from VS2008 was successful - and the webpart displays correctly in SharePoint

Hope this helps in your case

Nov 11, 2008 at 3:51 PM
I had the same error. Once I changed the code to point to XAPS1 the webpart deployed, but now I'm facing a new problem. I'm able to add the web part to the page, but it shows blank. I've tried both the Hello World and the Media Viewer web part. Both just show a blank web part. Any suggestions?
Nov 24, 2008 at 11:36 AM
Hi!
I have the same problem: when i am going to deploy the feature, it appears this error:

Failed to instantiate file "SL.XAML.HelloWorld.xap" from module "(null)": Source path "SL.XAML.HelloWorld.xap" not found.   at Microsoft.SharePoint.Library.SPRequestInternalClass.EnableModuleFromXml(String bstrFeatureDirectory, String bstrUrl, String bstrXML)
   at Microsoft.SharePoint.Library.SPRequest.EnableModuleFromXml(String bstrFeatureDirectory, String bstrUrl, String bstrXML)

I haven't any idea how is the solution for this problem...
Could somebody help me, please?
thanks in advance.
Patri
Dec 7, 2008 at 12:17 AM
There could be a "File not found error" when adding webpart to a page.
I discovered, that it mean's I did't configure Sharepoint to work with Silverlight apps.
In Silverlight Blueprint for SharePoint Beta 2 Guidance you can find "sharepointconfiguration.mht" - it contains all the info.

Dec 7, 2008 at 1:00 AM
If you see blank page, try setting a breakpoint in app.xaml.cs  file in VS and attach to a proper w3wp.exe process.
I did so and realized,that this code never start. So I build a SL project in Studio, and upload  sl.xaml.helloworld.xap file from my debug\ folder to my XAPS library in the site by hand.
After all, it worked!
Feb 26, 2009 at 9:51 AM
Hi all,

When deploying your Silverlight application to a document library (like some of these samples do), be sure to create the document library BEFORE deploying the solution from Visual Studio (or stsadm).

If this is not done, this is what happens:
The folder XAPS (in this case) is actually created, but is not visible in the browser. Open SharePoint Designer, and you will see this folder, probably with your .xap file inside. Also, if you now go back to the browser and create a new document library called XAPS, it will get the url XAPS1, which many of you have reported about in this thread.

Solution:
Delete the XAPS folder in SharePoint Designer, and then create a new document library in the browser called XAPS, and then redeploy your solution.

Hope this helps.

Frank
Jun 4, 2009 at 6:07 PM
Edited Jun 4, 2009 at 6:20 PM

I am tryin to deploy the SL Media Viewer (2.0) on a server that does not have VS2008. (WSS3.0)

I setup a new DocLibrary named XAPS in the site collection. Verified this in SP Designer.

Made the following changes to the setup.bat file:

    set DefaultWebUrl=  http://s15345825
    set DefaultSiteUrl= http://s15345825

Ran the setup. I get an error about "Cannot find list for XAP" or something similar. I look at the Document Library and it has no files. I upload the SL.XAML.MediaViewer.XAP, and activate the feature at the site collection.

When I add try to add the webpart to the page, I get an "Cannot import Media Viewer web part".

I've tried everything that I can come up with.

Any ideas?

L

P.S. Same thing happes witH Helloworld. I get the "Failed to instantiate..." error. it almost seems like permissions.